const regex = /(\*\*Type de client\*\*[\s\S]*?)(?=\n\n\s*\nEst-ce que c'est une mission qui peut t'intéresser \?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\*\\*Type de client\\*\\*[\\s\\S]*?)(?=\\n\\n\\s*\\nEst-ce que c\'est une mission qui peut t\'intéresser \\?)', '')
const str = `Hello Guillaume,
Une nouvelle mission vient de tomber sur Impli et je pense qu'elle peut t'intéresser :
**Titre de la mission** : Expert Make - Isabelle GODEFROY
**Type de client** :
**Nombre d'employés** :
**Outil(s)** : Make
**Type de mission** :
**Début de la mission** :
**Budget indicatif** : 500 à 1 000 euros
**Description** :
Apprendre à interconnecter les outils : Zoom, gmail, contrat/attestations
google form ( évaluation, positionnement..),google agenda, Calendly.
En lien aussi avec Teachizy (plateforme LMS).
Merci
Est-ce que c'est une mission qui peut t'intéresser ?
Si oui alors il suffit juste à répondre à cet e-mail pour une mise en relation 🙂
Merci,
Edouard`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}