import Foundation
let pattern = ##"""
(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)
(?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])
(?P<pair>(?&string)\s*:\s*(?&value))
(?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})
)
(?&object)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
{
foo : bar,
baz : [aa, bb, ccc],
123 : 123,
obj : { foo : bar}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)