const regex = new RegExp('<div>(?=.*?2018).*?<\\/div>', 'gm')
const str = `<div> ffjdklfjdklfjs 2015 ddddd </div> sfsfsfsfsf <div> hkh/ <> -%=:;.éjhjk 2018 dsqkdlmqs </div> fdfdfd </div><div> ffjdklfjdklfjs 2023 ddddd </div> sfsfsfsfsf <div> hkh/ <> -%=:;.éjhjk 2018 / dsqkdlmqs </div> fdfdfd </div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}