import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class\\=\"custom\">(.*?)<\\/div>";
final String string = "<div><div class=\"custom\"><p>TEST</p><div>Another inner div</div><div class=\"another-class\">Some text</div></div></div>\n"
+ "<p>Another text</p>\n"
+ "<div><div class=\"hello\"><div class=\"custom another\" data-custom=\"test-data\"><div>Another inner div</div><p>TEST</p><div class=\"another-class\">Some text</div></div></div></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}