import re
regex = re.compile(r"construit en (lieu|plusieurs|parpaings|face|forme|immeuble|(\d+|\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\d+ fois|r\+\d+)", flags=re.MULTILINE)
test_str = ("[NE PAS TENIR COMPTE]\n"
"construit en lieu\n"
"construit en plusieurs\n"
"construit en parpaings\n"
"construit en face\n"
"construit en forme\n"
"construit en immeuble\n"
"construit en deux étapes\n"
"construit en ossature\n"
"construit en siporex\n"
"construit en plaques béton\n"
"construit en charpente \n"
"construit en rez-de-chaussé\n"
"construit en 2 phases\n"
"construit en cloison\n"
"construit en 3 fois \n"
"construit en r+1 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")