re = /(<othermeta content="V6" name="version"\/>)(?![\s\S]*<othermeta content="V7" name="version"\/>)
/m
str = 'I will search for V6
If i find V6, i\'ll check for V7 AFTER V7
If V7 does not exist i will match V6 and replace it
If V7 exists AFTER V6, i will NOT match V6
BUG: If V7 exists BEFORE V6, i will match V6 (i don\'t know how to create a REGEX that looks ahead and behind)
Test it by changing Vy below to V7 and the match will be gone.
BUG: If you change Vx to V7 it will still match V6.
<othermeta content="Vx" name="version"/>
<othermeta content="V5" name="version"/>
<othermeta content="V6" name="version"/>
<othermeta content="V6.1" name="version"/>
<othermeta content="V" name="version"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end