package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^T(\d+)H-`)
var str = `T16H-seg0001.m3u
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}