import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*\\*HEADERONE\\*\\*(?:\\r?\\n-\\s*\\[[^][]*].*)*";
final String string = "A body paragraph about other things. Lorem ipsom and all that\n\n"
+ "**HEADERONE**\n"
+ "- [x] Logged In\n"
+ "- [ ] Logged Out\n"
+ "- [x] Spun Around\n"
+ "- [x] Did the hokey pokey\n\n"
+ "Maybe a link here www.go_ogle.com \n\n"
+ "Another list that isn't important\n"
+ "- [ ] Thing one\n"
+ "- [ ] Thing two\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}