$re = '/^[^,\n]+,([^,\n]+)/m';
$str = 'Submitted By,Assigned,Closed
Name1,10,5
Name2,20,10
Name3,30,15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);