import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.\\/(.*\\.)RAW$";
final String string = "INPUT:\n"
+ "./Foo/Foo Bar/CL2/RA.W/DSC_09108.RAW\n\n"
+ "Desired result:\n"
+ "Volumes/Ram/CL2/RAW/DSC_09108.JPG\n";
final String subst = "$1JPG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}