#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)(?<style>[0-9]*)\\\\(?<color>[0-9]*)\\\\(?<size>[a-zA-Z0-9-]*(\\\\[.])?)(\\\\)?(?<lenght>(\\["])?[0-9]*(\\["])?)"
Local $sString = "70270\\1073\\34\\" & @CRLF & _
"83122\\1073\\38-42" & @CRLF & _
"92422\\1167\\L" & @CRLF & _
"70234\\1167\\38\\34\"" & @CRLF & _
"70242\\1001\\29\\." & @CRLF & _
"70222\\3040\\29\\32\"" & @CRLF & _
"70267\\1019\\30" & @CRLF & _
"81086\\1309\\XL" & @CRLF & _
"70246\\1001\\38\\\"32" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")