const regex = /(?<style>[0-9]*)\\\\(?<color>[0-9]*)\\\\(?<size>[a-zA-Z0-9-]*(\\\\[.])?)(\\\\)?(?<lenght>(\\["])?[0-9]*(\\["])?)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<style>[0-9]*)\\\\\\\\(?<color>[0-9]*)\\\\\\\\(?<size>[a-zA-Z0-9-]*(\\\\\\\\[.])?)(\\\\\\\\)?(?<lenght>(\\\\["])?[0-9]*(\\\\["])?)', 'ig')
const str = `70270\\\\1073\\\\34\\\\
83122\\\\1073\\\\38-42
92422\\\\1167\\\\L
70234\\\\1167\\\\38\\\\34\\"
70242\\\\1001\\\\29\\\\.
70222\\\\3040\\\\29\\\\32\\"
70267\\\\1019\\\\30
81086\\\\1309\\\\XL
70246\\\\1001\\\\38\\\\\\"32
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}