const regex = /(?:<select id=\"c1:swfield\" name=\"c1\">.*?)?<option value=\".*?\">(.*?)<\/option>(?:<\/select>)?/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<select id=\\"c1:swfield\\" name=\\"c1\\">.*?)?<option value=\\".*?\\">(.*?)<\\\/option>(?:<\\\/select>)?', 'gsm')
const str = `<select id="c1:swfield" name="c1"><option value="--">> All Makes</option>
<option value="1167">Acura</option>
<option value="1173">Alfa Romeo</option>
<option value="1564">Smart</option>
<option value="1836">Speranza</option>
<option value="1566">Ssang Yong</option>
</select>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}