$re = '/(?:<select id=\"c1:swfield\" name=\"c1\">.*?)?<option value=\".*?\">(.*?)<\/option>(?:<\/select>)?/sm';
$str = '<select id="c1:swfield" name="c1"><option value="--">> All Makes</option>
<option value="1167">Acura</option>
<option value="1173">Alfa Romeo</option>
<option value="1564">Smart</option>
<option value="1836">Speranza</option>
<option value="1566">Ssang Yong</option>
</select>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);