import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?\\+?([0-9]{1,3})?[- (]?\\(?([0-9]{3})?[-. )]*?\\(?([0-9]{3})[-. )]*?\\(?([0-9]{4})\\)?\\s?$";
final String string = "+1 210.867.5309\n"
+ "(210) 867 5309\n"
+ "867-5309\n"
+ "210-867-5309";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}