package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)
(\-?((\w+\.\^\(.*?\)|([\w\.\^]+))|(\(?\(([^\(\)]+)\)\)?))(((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?\(([^\(\)]+)\))
|
(\-?\(([^\(\)]+)\)((((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?((\w+\.\^\(.*?\)|([\w\.\^]+))|(\(?\(([^\(\)]+)\)\)?))))`)
var str = `(sdf^sdf*(-sd.f*-(23^3s)))*sdf
-(2.32^23)*-(df.df^78)+dfd(sfsf)
-df.d(sfs.f^sdf+323)/-13+sfdfsdf
(dfd^23sdf)-(234^dfd)
(dfd^23sdf)-(2.34^d.fd)*-(x-3)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}