import re
regex = re.compile(r"""
(\-?((\w+\.\^\(.*?\)|([\w\.\^]+))|(\(?\(([^\(\)]+)\)\)?))(((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?\(([^\(\)]+)\))
|
(\-?\(([^\(\)]+)\)((((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?((\w+\.\^\(.*?\)|([\w\.\^]+))|(\(?\(([^\(\)]+)\)\)?))))
""", flags=re.VERBOSE)
test_str = ("(sdf^sdf*(-sd.f*-(23^3s)))*sdf\n"
"-(2.32^23)*-(df.df^78)+dfd(sfsf)\n"
"-df.d(sfs.f^sdf+323)/-13+sfdfsdf\n"
"(dfd^23sdf)-(234^dfd)\n"
"(dfd^23sdf)-(2.34^d.fd)*-(x-3)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")