using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b(?:tlf|mobile?|tel(?:ephone)?)[.:\s]+)?(?:\(\+45\)|\+45)?\s*\d{2}(?:\s?\d{2}){3}(?!\d)";
string input = @"lkdjkljlkaf tel.: +45 09827374, +45 89895867, some kind of text...
mobil: +45 20802020, +45 20802001,
afsdfadsf tlf.: +45 5555 1212
tlf: +4567890202Girrafe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}