#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http[^\]]*"
Local $sString = "Lorem ipsum [http://domain.tld/] dolor." & @CRLF & _
"Lorem ipsum [https://domain.tld/] dolor." & @CRLF & _
"Lorem ipsum [https://domain.tld/index.html] dolor."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")