$re = '/\bDebit\s*\d*\s+([0-9,.]*)/m';
$str = 'Hello,
Please release.
Please find below the retail cash forecast that will be drafted xx/xx/xxxx.
RUN ID No. Amount Curr.
xxxxx - Direct Debit 13 10,706,855.69 USD
xxxxx - Direct Credit 213122 (10,365,481.96) USD
TOTAL 341,373.73 USD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);