using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w\h]+(?:, [\w\h]+)+$";
string substitution = @"";
string input = @"cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}