const regex = /^[\w\h]+(?:, [\w\h]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w\\h]+(?:, [\\w\\h]+)+$', 'gm')
const str = `cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);