const regex = /\bwith\b((?:(?!\bwith\b)[^,])*),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bwith\\b((?:(?!\\bwith\\b)[^,])*),', 'gm')
const str = `This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}