re = /[\?\&](?<params>[^=]+)=(?<values>[^&]+)/m
str = '/v1/customers/1/sites?includeContacts=True&showOnlyPrimarySites=True&pageNumber=1&pageSize=10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end