// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z][a-zA-Z\d]{6,}\d$").unwrap();
let string = "afoohi5
3foobar5
afoobarz
afoo-bar5
afoobar5
Pfoobarbaz8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}