$re = '/<\?php echo \$(.*?)\[(.*?)\];\s*\?>/m';
$str = '<?php echo $rsedit[customer_name]; ?>
<?php echo $rsedit[address]; ?>
<?php echo $rsedit[city]; ?>
<?php echo $rsedit[pincode]; ?>
<?php echo $rsedit[contact_no]; ?>
<?php echo $rsedit[email_id]; ?>';
$subst = "<?php echo \$$1['$2']; ?>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;