#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);"
Local $sString = "import { routerConfig } from '@portaal/routes/global.js';" & @CRLF & _
                "import WillyRouter from '@portaal/router.js';" & @CRLF & _
                "" & @CRLF & _
                "import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';" & @CRLF & _
                "import routesKennisbank from './routes/kennisbank.js';" & @CRLF & _
                "import routesWiki from './routes/wiki.js';" & @CRLF & _
                "" & @CRLF & _
                "const r = new WillyRouter();" & @CRLF & _
                "" & @CRLF & _
                "// Custom routes toevoegen, verwijderen etc" & @CRLF & _
                "r.add('custom_dms', routesKwaliteitsdocumenten);" & @CRLF & _
                "r.add('custom_wiki', routesWiki);" & @CRLF & _
                "r.add('custom_kennisbank', routesKennisbank);" & @CRLF & _
                "// r.changeByName('groep.informatie', {" & @CRLF & _
                "//     component: CustomComponent," & @CRLF & _
                "// });" & @CRLF & _
                "// r.removeByName('beeldbank-beelden-beeldbankClienten');" & @CRLF & _
                "" & @CRLF & _
                "Vue.use(VueRouter);" & @CRLF & _
                "" & @CRLF & _
                "const router = new VueRouter({" & @CRLF & _
                "    ...routerConfig," & @CRLF & _
                "    routes: r.getAll()," & @CRLF & _
                "});" & @CRLF & _
                "" & @CRLF & _
                "export default router;" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")