import re
regex = re.compile(r"const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);")
test_str = ("import { routerConfig } from '@portaal/routes/global.js';\n"
"import WillyRouter from '@portaal/router.js';\n\n"
"import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';\n"
"import routesKennisbank from './routes/kennisbank.js';\n"
"import routesWiki from './routes/wiki.js';\n\n"
"const r = new WillyRouter();\n\n"
"// Custom routes toevoegen, verwijderen etc\n"
"r.add('custom_dms', routesKwaliteitsdocumenten);\n"
"r.add('custom_wiki', routesWiki);\n"
"r.add('custom_kennisbank', routesKennisbank);\n"
"// r.changeByName('groep.informatie', {\n"
"// component: CustomComponent,\n"
"// });\n"
"// r.removeByName('beeldbank-beelden-beeldbankClienten');\n\n"
"Vue.use(VueRouter);\n\n"
"const router = new VueRouter({\n"
" ...routerConfig,\n"
" routes: r.getAll(),\n"
"});\n\n"
"export default router;\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")