#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)PAS_BEGIN_0009999(.*?)PAS_END_0009999"
Local $sString = "PAS_BEGIN_0009999" & @CRLF & _
" T71_MANUFACTURER_4=98" & @CRLF & _
" T71_COLOR_ID_7=000" & @CRLF & _
" T71_OS_7=08" & @CRLF & _
"PAS_END_0009999" & @CRLF & _
"" & @CRLF & _
"PAS_BEGIN_0009996" & @CRLF & _
" T72_VAS_SERVICE_IDENTIFIER_6=" & @CRLF & _
" T72_ORDER_NB_7=0003" & @CRLF & _
" T72_TECHNOLOGY_7=01" & @CRLF & _
"PAS_END_0009996" & @CRLF & _
"" & @CRLF & _
"TPV_BEGIN" & @CRLF & _
" PAS_20819001=3600000 " & @CRLF & _
"TPV_END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")