#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w:-]+$(?<!:)"
Local $sString = "aaa:bbb-cool" & @CRLF & _
"aaa:bbb-cool-" & @CRLF & _
"aaa-22-bbb_cool3" & @CRLF & _
"aaa:bbb-cool:" & @CRLF & _
"aaa_bbb-cool:" & @CRLF & _
"aaa_bbb-cool" & @CRLF & _
"bbbb:>dd" & @CRLF & _
"hihi%" & @CRLF & _
"大家好" & @CRLF & _
"0000000000" & @CRLF & _
"11111:2222:3333" & @CRLF & _
"11111:2222:3333:" & @CRLF & _
"DDD@@@1" & @CRLF & _
"大家好"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")