use strict;
my $str = 'aaa:bbb-cool
aaa:bbb-cool-
aaa-22-bbb_cool3
aaa:bbb-cool:
aaa_bbb-cool:
aaa_bbb-cool
bbbb:>dd
hihi%
大家好
0000000000
11111:2222:3333
11111:2222:3333:
DDD@@@1
大家好';
my $regex = qr/^[\w:-]+$(?<!:)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}