$re = '/^[\w:-]+$(?<!:)/m';
$str = 'aaa:bbb-cool
aaa:bbb-cool-
aaa-22-bbb_cool3
aaa:bbb-cool:
aaa_bbb-cool:
aaa_bbb-cool
bbbb:>dd
hihi%
大家好
0000000000
11111:2222:3333
11111:2222:3333:
DDD@@@1
大家好';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);