package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<Unit_Number>\d*)\s*[\/,\,]\s*(?P<Street_Number>\d*)\s*(?P<Street_Name>[a-zA-Z\s]*),?\s*(?P<State>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\s*(?P<Post_Code>\d{4})|
(?P<street_number>\d*)\s*(?P<street_name>[a-zA-Z\s]*),?\s*(?P<state>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\s*(?P<post_code>\d{4})`)
var str = `5/50 street rd suburb, NSW 2000
7 street rd suburb, NSW 2155`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}