import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Unit_Number>\\d*)\\s*[\\/,\\,]\\s*(?P<Street_Number>\\d*)\\s*(?P<Street_Name>[a-zA-Z\\s]*),?\\s*(?P<State>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\\s*(?P<Post_Code>\\d{4})|\n"
+ "(?P<street_number>\\d*)\\s*(?P<street_name>[a-zA-Z\\s]*),?\\s*(?P<state>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\\s*(?P<post_code>\\d{4})";
final String string = "5/50 street rd suburb, NSW 2000\n"
+ "7 street rd suburb, NSW 2155";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}