const regex = /(?P<Unit_Number>\d*)\s*[\/,\,]\s*(?P<Street_Number>\d*)\s*(?P<Street_Name>[a-zA-Z\s]*),?\s*(?P<State>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\s*(?P<Post_Code>\d{4})|
(?P<street_number>\d*)\s*(?P<street_name>[a-zA-Z\s]*),?\s*(?P<state>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\s*(?P<post_code>\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<Unit_Number>\\d*)\\s*[\\\/,\\,]\\s*(?P<Street_Number>\\d*)\\s*(?P<Street_Name>[a-zA-Z\\s]*),?\\s*(?P<State>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\\s*(?P<Post_Code>\\d{4})|
(?P<street_number>\\d*)\\s*(?P<street_name>[a-zA-Z\\s]*),?\\s*(?P<state>NSW|ACT|NT|QLD|SA|TAS|VIC|WA)\\s*(?P<post_code>\\d{4})', 'g')
const str = `5/50 street rd suburb, NSW 2000
7 street rd suburb, NSW 2155`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}