import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ "^\n"
+ "([^-]+) # Capture everything not a dash\n"
+ "\\s+-\\s+ # Match white space(s) dash white space(s)\n"
+ "((?1)) # Capture everything not a dash\n"
+ "\\.mp3\n"
+ "$\n";
final String string = "My Test Name - h1n.mp3\n"
+ "Arist of Song - Title of song.mp3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}