re = /^(0|[1-9]{1,3})([.,][1-9]{1,3})?$/m
str = '0
9
999
9999
99999
0.9
0.0
0.99
0,999
0.9999
99,999
999.999
9999.999
999.9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end