package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\()?(?P<area>\d{3})(?(1)\))[ -]?(?P<fst>\d{3})-?(?P<lst>\d{4})$`)
var str = `(321) 123-4567
(321) 1234567
321-123-4567
321123-4567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}