// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\d]+[.]{0,1}[\d]+[x|X|*][\d]+[.]{0,1}[\d]+[x|X|*][\d]+[.]{0,1}[\d]+").unwrap();
let string = "12*19.2*2000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}