using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+(\.\w+)+$";
string input = @"aaa.bbb
aaa.bbb.ccc
aaa.bbb.ccc.ddd
.aaa
aaa.
.aaa.
aaa.bbb.
aaa.bbb.ccc.
aaa..bbb...ccc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}