re = /^\w+(\.\w+)+$/m
str = 'aaa.bbb
aaa.bbb.ccc
aaa.bbb.ccc.ddd
.aaa
aaa.
.aaa.
aaa.bbb.
aaa.bbb.ccc.
aaa..bbb...ccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end