// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[0-9]{1,3}\.){1,3}[0-9]{1,3}").unwrap();
let string = "192.168.10.1
10.5.6.7
234.4.5.6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}