using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[example\.com\].*(\[(?:(?!example\.com).)*?\])";
string input = @"[example.com]0.100.251.10.100.251.200.251.3[example.com]
10.100.251.22
10.100.251.3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}