import Foundation
let pattern = #"^\[example\.com\].*(\[(?:(?!example\.com).)*?\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[example.com]0.100.251.10.100.251.200.251.3[example.com]
10.100.251.22
10.100.251.3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)