$re = '/\/research\//m';
$str = '/research/the-123s-of-school-choice/
';
$subst = "\/research-library/?report=";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;