$re = '/(?<!@\{)(?<=\{).*?(?=\})/';
$str = ' 1 {eww} r23r23{fetwe}
2 #{d2dded}
3 @{d2dded}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);