Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
`
^(?:\D+)?(?:(?:[5-6](?:(?:\.|\,)[1-9])?)|(?:[6-7](?:(?:\.|\,)0)?))(?:(?:\s?pol)|"|''|\x60|'|´|”)?(?:.*)
`
s
Test String
New
4.5 polegadas (~ 64,3% relação tela-corpo) 5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3 5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3 5"-6" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3 ^(?:(6(?:\.|\,)0)|(5(?:\.|\,)[1-9]))(.*) \s?(?:(?:\d+)(?:\.|\,)?(?:\d+)?)(?:"|''|\x60|'|´|”) (?:(5(?:\.|\,)0)|(4(?:\.|\,)[1-9]))(.*) (4(?:\.|\,)[1-9])(.*) => 4-5 (5(?:\.|\,)[0]))(.*) => 4-5