$re = '/(R[0-9][0-9][0-9][0-9][0-9](?=\w+$))/m';
$str = 'Text R77777 R120943 R11114_8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);