$re = '/(?:15620450000|VS|00)\d{8}/m';
$str = '1562045000012345678
VS12345678
0012345678
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);