const regex = /(?:\bdigit-|\s|^)(\d{4})(?=[.?\s]|-digit\b|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bdigit-|\\s|^)(\\d{4})(?=[.?\\s]|-digit\\b|$)', 'gm')
const str = `1234 Lorem ipsum 3400-digit, sit amet 5000 consectetur adipisicing elit. Natus, explicabo 6700? Itaque iure ipsum laboriosam, ex nemo delectus iste quia cupiditate digit-9134? Iste nam digit-2456 at voluptate est 8456-digit? At excepturi quis voluptatibus 7500. 1235`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}